Updated system requirements coming soon